Home / Overig / PC Programma's / Synology Netwerk shares verbinden niet na opstarten

Synology Netwerk shares verbinden niet na opstarten

Misschien heb jij wel net zoals ik last van het feit dat de netwerk locaties niet netjes verbinding na opstarten. Nadat ik mijn laptop heb opgestart dan krijg ik rechts onderin de melding dat de netwerk locaties niet verbonden zijn. Aangezien ik dit zo zat was heb ik op internet zitten zoeken en misschien helpt het jou ook wel de melding te voorkomen om deze synology netwerkshares wel goed te laten verbinden. Wat ik nog wel even wil zeggen is dat dit probleem niet aan de synology ligt maar aan Microsoft Windows.

Als eerste maken we een .vbs script met de volgende inhoud:

Set WshShell = CreateObject(“WScript.Shell”)
WshShell.RUN “cmd /c c:\scripts\netuse.bat“, 0

Pas het dik gedrukte aan naar de locatie waar je het batch script plaatst. Dit doe je door in Notepad de tekst te plakken en het bijvoorbeeld op te slaan als startup.vbs. Plaats deze in de startup folder in het start menu. In Windows 8 kan je dit doen door in Start met de rechter muisknop op een shortcut te drukken en dan te kiezen voor “open file location”

Nu moeten we nog het netuse.bat bestand aanmaken. Dit doe je ook in notepad, waar je de volgende in plakt:

@echo off
set delay=30
ping localhost -n %delay%
Net use W: \\ADRESNAS\SHARENAAM

Pas het adres naar wens aan en sla het bestand op. Wanneer je nu zal herstarten, dan kan het nog even duren, maar je zult zien dat je hierna netjes overal verbinding hebt. In ieder geval zijn de rode kruisjes weg.

About Ronald

Ik ben de trotse bezitter van een DS1513+ en een DS114. De DS212+ die ik hiervoor had vind ik te langzaam om goed Wordpress te kunnen gebruiken. Inmiddels alweer een paar jaar ervaring! Heb je vragen? Stuur mij een berichtje via Hangouts

4 comments

  1. Heb het geprobeerd maar krijg een foutmelding in regel 1 positie 29….
    Ik heb windows 7 home premium.
    Enig idee hoe ik dit oplos?

  2. Krijg je dit op uitvoeren van VBS script of netuse file? Je kan de laatste ook proberen handmatig te starten. Als het alleen met VBS is dan ben ik zeer benieuwd wat je op regel 29 hebt staan, want zoveel regels staan er namelijk niet in het script.

  3. Beste Ronald,
    Het gaat om het vbs bestand. Op regel 1 positie 29 staat volgens mij een aanhalingsteken.
    Ik kijk vanavond alles nog een keer na voor de zekerheid want ik ben hier nog niet zo handig in.
    Groet, Paul

  4. Ik heb nog een andere oplossing gevonden:
    -> Configuratiescherm -> weergeven grote pictogrammen -> referentiebeheer -> dan bij windows referenties het ip adres, inlognaam en wachtwoord van je NAS invoeren.
    Werkt tot nu toe uitstekend.

Geef een reactie